Функция ЕСЛИ

Функция ЕСЛИ

Функция ЕСЛИ — одна из самых популярных функций в Excel. Она позволяет выполнять логические сравнения значений и ожидаемых результатов. Самая простая функция ЕСЛИ означает следующее:

  • ЕСЛИ(это истинно, то сделать это, в противном случае сделать что-то еще)

Поэтому у функции ЕСЛИ возможны два результата. Первый результат возвращается в случае, если сравнение истинно, второй — если сравнение ложно.

 

Технические подробности

Простые примеры функции ЕСЛИ

Ячейка D2 содержит формулу =ЕСЛИ(C2="Да";1;2)

  • =ЕСЛИ(C2=”Да”;1;2)

В примере выше ячейка D2 содержит формулу: ЕСЛИ(C2 = Да, то вернуть 1, в противном случае вернуть 2)

Ячейка D2 содержит формулу =ЕСЛИ(C2=1;"ДА";"НЕТ")

  • =ЕСЛИ(C2=1;”Да”;”Нет”)

В этом примере ячейка D2 содержит формулу: ЕСЛИ(C2 = 1, то вернуть текст “Да”, в противном случае вернуть текст “Нет”)

Как видите, функцию ЕСЛИ можно использовать для сравнения и текста, и значений. А еще с ее помощью можно оценивать ошибки. Вы можете не только проверять, равно ли одно значение другому, возвращая один результат, но и использовать математические операторы и выполнять дополнительные вычисления в зависимости от условий. Для выполнения нескольких сравнений можно использовать несколько вложенных функций ЕСЛИ.

ПРИМЕЧАНИЕ : Если вы используете текст в формулах, заключайте его в кавычки (пример: “Текст”). Единственное исключение — слова ИСТИНА и ЛОЖЬ, которые Excel распознает автоматически.

Начало работы

Прежде чем написать оператор ЕСЛИ, подумайте, чего вы хотите достичь. Какое сравнение вы пытаетесь выполнить? Написать оператор ЕСЛИ не сложнее, чем выстроить в уме логическую цепочку “что должно произойти, если это условие выполнено, и что должно произойти, если нет?” Всегда следите за тем, чтобы ваши действия выполнялись в логической последовательности, иначе формула не будет делать то, для чего предназначена. Это особенно важно при создании сложных (вложенных) операторов ЕСЛИ.

Еще примеры функции ЕСЛИ

Ячейка D2 содержит формулу =ЕСЛИ(C2>B2;"Превышение бюджета","В пределах бюджета")

  • =ЕСЛИ(C2>B2;”Превышение бюджета”;”В пределах бюджета”)

В примере выше функция ЕСЛИ в ячейке D2 означает: ЕСЛИ(C2 больше B2, то вернуть текст “Превышение бюджета”, в противном случае вернуть текст “В пределах бюджета”)

Ячейка E2 содержит формулу =ЕСЛИ(C2>B2;C2-B2;"")

  • =ЕСЛИ(C2>B2;C2-B2;0)

На рисунке выше мы возвращаем не текст, а результат математического вычисления. Формула в ячейке E2 означает:ЕСЛИ(значение “Фактические” больше значения “Плановые”, то вычесть сумму “Плановые” из суммы “Фактические”, в противном случае ничего не возвращать).

Ячейка F7 содержит формулу ЕСЛИ(E7="Да";F5*0,0825;0)

  • =ЕСЛИ(E7=”Да”;F5*0,0825;0)

В этом примере формула в ячейке F7 означает: ЕСЛИ(E7 = “Да”, то вычислить общую сумму в ячейке F5 и умножить на 8,25 %, в противном случае налога с продажи нет, поэтому вернуть 0)

Рекомендации по использованию констант

В последнем примере текстовое значение “Да” и ставка налога с продажи (0,0825) введены прямо в формулу. Как правило, литеральные константы (значения, которые время от времени требуется изменять) не рекомендуется вводить прямо в формулу, поскольку в будущем их может быть затруднительно найти и изменить. Гораздо удобнее помещать константы в собственные ячейки, в которых они будут доступны и их можно будет легко найти и изменить. В нашем случае все в порядке, но здесь используется только одна функция ЕСЛИ, а ставка налога с продажи будет редко изменяться. Даже если она изменится, вы сможете легко изменить ее в формуле.

Использование функции ЕСЛИ для проверки ячейки на наличие символов

Иногда требуется проверить, пуста ли ячейка. Обычно это делается, чтобы формула не выводила результат при отсутствии входного значения.

Ячейка E2 содержит формулу =ЕСЛИ(D2=1;"Да";ЕСЛИ(D2=2;"Нет";"Возможно"))В этом случае мы используем ЕСЛИ с функцией ЕПУСТО :

  • =ЕСЛИ(ЕПУСТО(D2);”Пустая”;”Не пустая”)

Эта формула означает: ЕСЛИ(ячейка D2 пуста, вернуть текст “Пустая”, в противном случае вернуть текст “Не пустая”). Вы также можете легко использовать собственную формулу для состояния “Не пустая”. В следующем примере вместо функции ЕПУСТО используются знаки “”. “” — фактически означает “ничего”.

Проверка пустоты ячейки — ячейка E2 содержит формулу =ЕСЛИ(ЕПУСТО(D2);"Пустая";"Не пустая")

  • =ЕСЛИ(D3=””;”Пустая”;”Не пустая”)

Эта формула означает: ЕСЛИ(в ячейке D3 ничего нет, вернуть текст “Пустая”, в противном случае вернуть текст “Не пустая”). Вот пример распространенного способа использования знаков “”, при котором формула не вычисляется, если зависимая ячейка пуста:

  • =ЕСЛИ(D3=””;””;ВашаФормула())

    ЕСЛИ(в ячейке D3 ничего нет, не возвращать ничего, в противном случае вычислить формулу).

Пример вложенных функций ЕСЛИ

Если у простой функции ЕСЛИ есть только два результата (ИСТИНА и ЛОЖЬ), то у вложенных функций ЕСЛИ может быть от 3 до 64 результатов.

Использование знаков "" для проверки пустоты ячейки — ячейка E3 содержит формулу =ЕСЛИ(D3="";"Пустая";"Не пустая")

  • =ЕСЛИ(D2=1;”ДА”;ЕСЛИ(D2=2;”Нет”;”Возможно”))

На приведенном выше рисунке говорит формулу в E2: ЕСЛИ (D2 равняется 1 вернитесь «Да», в противном случае ЕСЛИ (D2 равно 2, а затем возврата ответ “Нет”, в противном случае возвращает “Может быть”)). Обратите внимание, что имеется две закрывающие скобки в конце формулу. Те, необходимых для завершения обе функции ЕСЛИ, и при попытке ввести формулу без оба закрывающие скобки Excel попытается исправить для вас.

Небольшое предупреждение

Excel позволяет использовать до 64 вложенных функций ЕСЛИ, но это вовсе не означает, что так и надо делать. Почему?

  • Нужно очень крепко подумать, чтобы выстроить последовательность из множества операторов ЕСЛИ и обеспечить их правильную отработку по каждому условию на протяжении всей цепочки. Если при вложении операторов ЕСЛИ вы допустите малейшую неточность, формула может сработать в 75 % случаев, но вернуть непредвиденные результаты в остальных 25 %. К сожалению, шансов отыскать эти 25 % немного.
  • Работа с множественными операторами ЕСЛИ может оказаться очень трудоемкой, особенно если вы вернетесь к ним через какое-то время и попробуете разобраться, что пытались сделать вы или, и того хуже, кто-то другой.
  • Несколько операторов, ЕСЛИ требуется несколько открывающих и закрывающих скобок (), которой может быть сложно управлять в зависимости от того, как сложная формула примет вид.

Распространенные неполадки

Проблема Возможная причина
0 (ноль) в ячейке Не указан аргумент значение_если_истина или значение_если_ложь. Чтобы возвращать правильное значение, добавьте текст двух аргументов или значение ИСТИНА/ЛОЖЬ.
“#ИМЯ?” в ячейке Как правило, это указывает на ошибку в формуле.